Follow me on GitHub

升级发表的日志

成功升级到wp3.0

WordPress3.0正式版今天发布了,前几天就开始在本地调试rc3版本多站点功能,感觉挺好的。

升级后,插件完全没有问题,不过要开启多站点功能,要求常规选项中的“博客地址”和“WordPress安装地址”必须是相同的,这样kainy就不得不现改变下站点的结构咯,不过还好,挺容易的,把安装地址改到根目录,然后程序文件都移动出来就ok啦;然后就是开通多站点功能前,所有插件必须停用,修改wp-config文件开启多站点功能后重新启动插件,这也好办;另外一个需要注意的就是,如果要用二级域名作为子站点的域名的话,要求博客程序必须安装在根目录,否则就只能把子站点放到子目录咯,不过也有办法通过修改.htaccess文件来进行重定向来支持二级域名绑定功能就是了。

升级后马上就能体验到一些不错的细节啦,就拿自己看到的几点来说下:

1.修改管理员邮箱时候有这样一个提示: More >

用一条代码判断并提示ie6用户升级

万恶的IE6,一直是网页设计人员心中的痛,虽然有很多解决兼容性办法的方法,但我觉得直接判断网页是不是IE6的比较直接有效,如果是IE6则像用户提示升级,并提供升级的链接,如果用户仍然“执迷不悟”的话,那也不必强求了,毕竟顾客才是上帝嘛,如果他们关闭了提示信息也就没必要再多唠叨了,所以可以通过cookie记录,关闭后不再显示提示信息。

实现代码(gbk编码的网页中):


<!--[if lt IE 7]>
<script src="http://kainy.googlecode.com/svn/trunk/ie6/killie6.gbk.js"></script>
<![endif]-->

实现代码(utf-8编码的网页中):


<!--[if lt IE 7]>
<script src="http://kainy.googlecode.com/svn/trunk/ie6/killie6.utf-8.js"></script>
<![endif]-->
.
将以上代码加入网页的 head 中,这样以后,用ie6打开该页面的访客就会在浏览器右下角显示如下图片啦:
.
.

QQ在线状态 V2.0正式发布

今天收到来自:QQ在线状态项目组<wp@tencent.com>的邮件,说是 “QQ在线状态”V2.0正式发布,解决了QQ2009用户点击“在线状态”后须添加好友才能对话的问题,提高了临时会话使用的安全性。琢磨了一番,共享一些资料吧。

qq1、什么是”在线状态”(Web pres-ence)?

“在线状态”是腾讯公司提供的一种快速沟通服务,该服务可以让您在不加好友的情况下和域中的朋友发起临时会话。您只需要将生成的代码嵌入至您网页上对应的页面代码中,如:日志、个人网页、邮件签名档等地方,即可拥有您的”在线状态”;从而进行个人沟通、商业交流或提供线上即时客户服务。

对于社区以及C2C业务的服务商来说,”在线状态”能帮助您满足用户之间强沟通的需求,提高已有用户的黏性以及满意度,从而不断地扩大网站的影响力以及知名度。

2、我已经在用”在线状态”了,还需要升级至”在线状态”V2.0吗?

如果您是2008年以前生成的“在线状态”,则需要升级。因为“在线状态”V2.0解决了QQ2009的用户点击后必须加为好友才能会话的问题。 More >

国内的空间再次被关停

私密

晚上回来一网友提醒我,原来那个博客打不开了,登陆IDC商的管理面板才发现是“因其他原因被暂停服务”,经过一番查问,才知道原来又是敏感字被检测到了,Kainy就纳闷了,这都好几天前停止更新的博客了,你还能有什么可敏感呢? 而所谓的敏感,也就出自Kainy原来转自网络的《网友恶搞版《2010年央视春晚节目单》》一文(一篇恶搞文章能有多“敏感”),刚在月光博客看到下面文字才知道,估计是又一波严打加强审核力度的结果了

今天下午消息,新网今天对多个知名网站,包括知名社交网站51.com、知名IT资讯平台it168.com、知名博客托管服务blogbus.com的域名进行锁定,停止其域名解析,新网称该上述网站含有淫秽色情等非法信息。

由此想起高中时同学间流行的一个说法“习惯了就好”,是啊,除了习惯还能怎样呢,说来那空间提供商也是难做了,不信请看下面这段聊天记录: More >